JUNE is not available

Incident Report for JUNE

Postmortem

On October 21, between 3:40 PM and 4:00 PM (CET), JUNE users saw a message indicating that the connection to JUNE could not be established.

The interruption was caused by an unexpected combination of technical issues that temporarily affected our infrastructure. While one of our internal services experienced unusually high memory usage, it overloaded a specific part of the system and triggered automatic restarts of some connected services — including the notification service. While all other of the services in JUNE operate as multi instance this service currently has to operate as a single instance and its restart took longer than usual, which resulted in a downtime.

What we’ve done to prevent this in the future

  • We’ve added memory usage limits to the affected service to prevent similar overloads.
  • Improvements to reduce restart times are currently in testing and will be rolled out soon.
  • We are also working on enabling multiple instances of the notification service, which will increase its resilience and availability.

We sincerely apologize for the disruption and appreciate your understanding.

Posted Oct 26, 2025 - 21:33 CET

Resolved

We have successfully fixed the issue. The system is fully operational again.
Posted Oct 21, 2025 - 16:26 CEST

Monitoring

Monitoring is ongoing.
Posted Oct 21, 2025 - 16:05 CEST

Identified

We have fixed the immediate issue. JUNE is available again. We are investigating the root cause and are monitoring.
Posted Oct 21, 2025 - 16:03 CEST

Investigating

JUNE is not available right now. We are investigating with highest priority and will inform once we have new information.
Posted Oct 21, 2025 - 15:51 CEST
This incident affected: Login, Files & Contacts, Upload files, Document Viewer, Actions & Workflows, JUNE Assistant, JUNE Search, JUNE Extract, Reports, Administration, and Postbox.